Go to shopping cart

Unable to Install the iCamera (1st Gen)

  • Ensure that your smartphone and CubeOne are on the same Wi-Fi network during setup.
  • Once you see the prompt “Found new iCamera, add now?” follow the app’s instructions to complete the setup process.
  • Ensure that the Wi-Fi password you entered is correct for both boxes.
  • Be sure to unplug the Ethernet cable promptly as per the instructions.
  • You should now be able to view the iCamera's live video.

If you're prompted to reset the camera,

  1. On the back of the camera, you'll find a small hole labeled "Reset" on the right.
  2. Insert a small paper clip or pin into the hole and you should feel a small click.
  3. Press down and hold the button in place for 30 seconds.
  4. Release the button and the iCamera will begin to rotate which indicates it has successfully been reset.

If you've unplugged the network cable, but still cannot view the live video, 

  • After unplugging the network cable, wait approximately 60 seconds, or until the iCamera stops rotating
  • If you've unplugged the network cable AFTER tapping Done in the app, unplug the power source from the iCamera, wait 15 seconds, and plug it back in.  Wait until the iCamera completes rotation.
  • If the above mentioned does not solve the issue, you can setup your iCamera’s Wi-Fi again. To do so,
    1. Plug the network cable back into the iCamera
    2. Tap Settings (located on the upper right corner of the iCamera page)
    3. Select iCamera Wi-Fi Setting and follow the instructions to setup the iCamera’s Wi-Fi again.
Still need help? Submit a request
Powered by Zendesk